The ParaView Framework: Introduction, Overview and Tips

Andrew Bauer
10/17/2016
• Collaborative software R&D: algorithms & applications, image & data analysis, support & training
• Industry, government, academia
• Best known for open source toolkits and applications
• 129 employees in US: ⅓ Masters, ⅓ PhD
• Founded in 1998; $28M revenue 2011
• 13 employees in France (Kitware SAS)
We Grow Open Source Solutions

- No licensing costs; proven in products
- Funding & contributions from around the world
- VTK—the Visualization Toolkit
- ParaView—Large data visualization application
- ITK—Insight image analysis Toolkit
- CMake—cross-platform build system
  - CDash, CTest, CPack, software process tools
- OpenView / Tangelo—Informatics and infovis
- Kiwi & VES—Mobile / GLES rendering
- IGSTK, Lesion Sizing Toolkit, CTK, vx1, Open Chemistry Project, VolView, tubeTk, and more…
High Performance Computing

HPC Analysis & Visualization

Informatics, Analytics & Data

Open-Source Tools

Simulation Lifecycle

Computational Chemistry

Kitware
COMPUTATIONAL MODEL BUILDER
Designed to support customizable simulation workflows
Simulation Attributes

```
<TopLevel Section="Time" UIName="Time">
  <!-- time control -->
  <InformationValue TagName="JulianDay" UIName="Julian start day:">
    <Group Name="General"/>
    <Advanced/>
    <ValueType Name="int"/>
    <DefaultValue Value="0"/>
    <Constraint Type="Minimum" Inclusive="Yes" Value="0"/>
    <Option Default="OFF"/>
  </InformationValue>

  <InformationValue TagName="StartTime" UIName="Start time:">
    <Group Name="General"/>
    <MultiValue>
      <InputValue Index="1"/>
      <ValueType Name="double"/>
      <DefaultValue Value="0"/>
      <Constraint Type="Minimum" Inclusive="Yes" Value="0"/>
    </InputValue>
    <InputValue Index="2"/>
    <ValueType Name="int"/>
    <Constraint Type="Discrete" DefaultValueIndex="0">
      <Enum Value="0" Name="Seconds"/>
      <Enum Value="1" Name="Minutes"/>
      <Enum Value="2" Name="Hours"/>
      <Enum Value="3" Name="Days"/>
      <Enum Value="4" Name="Weeks"/>
      <Enum Value="5" Name="Months"/>
      <Enum Value="6" Name="Years"/>
    </Constraint>
    </InputValue>
    </MultiValue>
  </InformationValue>

  <InformationValue TagName="EndTime" UIName="End time:">
    <Group Name="General"/>
    <MultiValue>
      <InputValue Index="1"/>
      <ValueType Name="double"/>
      <DefaultValue Value="162"/>
      <Constraint Type="Minimum" Inclusive="Yes" Value="0"/>
    </InputValue>
  </InformationValue>
```

---

```
<Check Mark>
  <Label>Show Advanced</Label>
  <Checkbox>
    <Text>Julian start day:</Text>
    <Input Value="0"/>
  </Checkbox>
  <Text>Start time:</Text>
  <Input Value="0"/>
  <Text>End time:</Text>
  <Input Value="162"/>
  <Label>Time step size:</Label>
  <Text>Use adaptive time stepping</Text>
  <Input Value="1"/>
  <Label>Output times:</Label>
  <Text>Specify an interval at which the solution is written. Interval:</Text>
  <Input Value="1"/>
  <Text>Print adapted meshes</Text>
</Check Mark>
```
Visualizing Attribute Information on the Domain
VTK & PARAVIEW HIGHLIGHTS
New Rendering Options

• ParaView 5.1/VTK 7 has massive rendering updates through newer OpenGL API
  – EGL & OpenSWR available for offscreen rendering
  – Point cloud rendering
• FX Anti-aliasing*
• Ray tracing with OSPRay*
  – New option for rendering
  – Independent of OpenGL
• Volume rendering

* In upcoming VTK 7.1 and ParaView 5.2 releases
Fast Approximate Anti-Aliasing

- Settings in Edit→Settings→Render View
- Anti-aliasing done after image is generated
GL points (L) and sprites (C) lack the meso-scale clues that OSPRay's (R) ambient occlusion provides. Crack propagation data thanks Souchin Deng @ INL.
OSPRay Options

OSPRay Rendering section in Properties tab

- Enable OSPRay – check box to enable ray casting
- Shadows – check box to enable viewing shadows
- Samples per Pixel – helps with anti-aliasing
- Ambient Samples – indirect illumination effects from reflections of nearby objects
- Max Frames – progressive rendering similar to level-of-details effect
- Light Scale – global brightness modifier
ParaView Catalyst

- ParaView as a toolkit for *in situ* analysis and visualization
  - Batch & interactive functionalities
  - Memory and compute efficient
  - Hero run with 1M MPI ranks on IBM BG/Q Mira@ANL

- Advantages of *in situ*
  - Avoids IO bottleneck
  - Access to more data
  - Faster time to solution
  - Faster run-time checks
Five Orders of Magnitude Between Compute and I/O Capacity on Titan Cray System at ORNL

Image courtesy Ken Moreland (Sandia)
Better Insight

Full dump every 400 time steps versus *in situ* every 25 time steps

Animation courtesy Sean Ziegeler (PETTT/Engility)
Multi-Platform/Access
VTK-m

- VTK-m is a toolkit of scientific visualization algorithms for emerging processor architectures
  - Supports the fine-grained concurrency for data analysis and visualization algorithms
  - Provides abstract models for data and execution that can be applied to a variety of algorithms across many different processor architectures
- Targets architectures where MPI process per core won’t yield best performance
Why VTK-m?

**GPU (NVIDIA)**
- Sub-architectures:
  - Fermi, Kepler, Maxwell
- Multiple Memory Types:
  - Global, shared, constant, texture
- Limited Memory Size
- 1000s of threads
  - Grids, blocks, and warps

**CPU/MIC**
- Multiple ISAs:
  - Vector unit widths: 2, 4, 8 / 16
- Single Memory Type
  - Except for cache & HSM
- “Unlimited” Memory Size
- Up to 60/260 threads
  - No explicit organization
    - Except for Xeon Phi KNL?
Performance Portability

Architecture

Algorithm

Backend

Algorithm

Algorithm
Very Quick Intro to ParaView
An open-source application and architecture for display and analysis of scientific datasets

- **Application** - you don’t have to write any code to analyze your data
- **Architecture** - designed to be extensible if you want to code
  - Custom apps, plugins, Python scripting, Catalyst for *in situ*, ParaViewWeb
- **Open-source** – BSD 3-clause license

- **Display** - excels at traditional scientific vis qualitative 3D rendering
- **Analysis** - data drill down through charts, stats, all the way to values
- **ParaView** – designed for parallel use: scales from notebooks to world’s largest supercomputers
User Interface

- Menu Bar
- Toolbars
- Pipeline Browser
- Object Inspector
- View(s)
VTK & ParaView Lexicon

- **Filter**: an object that operates on data: reads its inputs and produces one or more outputs (aka pipeline object)
  - **Reader**: reads a file and produces an output
  - **Source**: produces an output, e.g. a cylinder
- **View**: visual information contained in window, e.g. 2D, 3D, spreadsheet
- **Property**: a filter or view parameter the user can set (e.g. file name, slice plane location, camera angle)
- **Client**: the GUI or Python connection to the server
- **Server**: computer where the data and filters exist
  - **Built-in Server**: client executable also running server
  - **Remote Server**: server is a separate process from the client
Help

- Windows & Linux: F1 in the GUI
- Mac: Command+Shift+/
- Mouse hover
- Online help
  - The ParaView Guide
  - The ParaView Tutorial
  - ParaView Mailing Lists
  - ParaView Wiki
  - http://www.paraview.org/documentation/
How to Use ParaView

1. Read in data: File → Open, hit •
   • Over 100 file formats supported
   • Help/Readers - readers compiled in

2. Add a filter to process data:
   • Tune filter properties, hit •
   • Repeat Step 2 as needed

3. Tune Display (for all Filter, View pairs) and View (for all Views) parameters

4. Save datasets, rendered results (screenshot or animation) or application state
File→Open


- ParaView Data (.pvd)
- VTK (.vtp, .vtu, .vti, .vts, .vtr)
- VTK Legacy (.vtk)
- VTK Multi Block (.vtm, .vtmb, .vtmg, .vtd, .vthb)
- Partitioned VTK (.pvtu, .pvti, .pvt, .pvtv)
- ADAPT (.nc, .cdf, .elev, .ncd)
- ANALYZE (.img, .hdr)
- ANSYS (.inp)
- AVS UCD (.inp)
- BOV (.bov)
- BYU (.g)
- CAM NetCDF (.nc, .ncdf)
- CCSM MTSD (.nc, .cdf, .elev, .ncd)
- CCSM STSD (.nc, .cdf, .elev, .ncd)
- CEAucd (.ucd, .inp)
- CMAT (.cmat)
- CML (.cml)
- CTRL (.ctrl)
- Chombo (.hdf5, .h5)
- Claw (.claw)
- Comma Separated Values (.csv)
- Cosmology Files (.cosmo, .gadget2)
- Curve2D (.curve, .ultra, .ult, .u)
- DDCMD (.ddcmd)
- Digital Elevation Map (.dem)
- Dyna3D (.dyn)
- EnSight (.case, .sos)
- Enzo boundary and hierarchy
- ExodusII (.e, .exe, .ex2, .ex2v, .etc)
- ExtrudedVol (.exvol)
- FVCOM (MTMD, MTSD, Particle, STSD)
- Facet Polygonal Data
- Flash multiblock files
- Fluent Case Files (.cas)
- GGCM (.3df, .mer)
- GTG (.h5)
- GULP (.trg)
- Gaussian Cube File (.cube)
- JPEG Image (.jpg, .jpeg)
- LAMMPS Dump (.dump)
- LAMMPS Structure Files
- LIDI (.nc, .cdf, .elev, .ncd)
- LIDI Particle (.nc, .cdf, .elev, .ncd)
- LS-DYNA (.k, .lsdyna, .d3plot, .d3plot)
- M3DCI (.h5)
- MFIX Unstructured Grid (.RES)
- MM5 (.mm5)
- MPAS NetCDF (.nc, .ncdf)
- Meta Image (.mhd, .mha)
- Miranda (.mir, .raw)
- Multilevel 3d Plasma (.m3d, .h5)
- NASTRAN (.nas, .f06)
- Nek5000 Files
- Nrrd Raw Image (.nrrd, .nhdr)
- OpenFOAM Files (.foam)
- PATRAN (.neu)
- PFLOTTRAN (.h5)
- PLOT2D (.p2d)
- PLOT3D (.xyz, .q, .x, .vp3d)
- PLY Polygonal File Format
- PNG Image Files
- POP Ocean Files
- ParaDIS Files
- Phasta Files (.pht)
- Pixie Files (.h5)
- ProSTAR (.cel, .vrt)
- Protein Data Bank (.pdb, .ent, .pdb)
- Raw Image Files
- Raw NRND image files (.nrrd)
- SAMRAI (.samrai)
- SAR (.sar)
- SAS (.sasgeom, .sas, .sasdata)
- SESAME Tables
- SLAC netCDF mesh and mode data
- SLAC netCDF particle data
- Silo (.silo, .pdb)
- Spherical (.spherical, .sv)
- SpyPlot CTH
- SpyPlot (.case)
- SpyPlot History (.hscth)
- Stereo Lithography (.stl)
- TFT Files
- TIFF Image Files
- TSurf Files
- Tecplot ASCII (.tec, .tp)
- Tecplot Binary (.plt)
- Tetrad (.hdf5, .h5)
- UNIC (.h5)
- VASP CHGCA (.CHG)
- VASP OUT (.OUT)
- VASP POSTCAR (.POS)
- VPIC (.vpc)
- VRML (.wrl)
- Velodyne (.vld, .rst)
- VizSchema (.h5, .vsh5)
- Wavefront Polygonal Data (.obj)
- WindBlade (.wind)
- XDMF and hdf5 (.xmf, .xdmf)
- XMol Molecule

And growing...
Filter Properties and the Apply Button

• ParaView is meant to process large data – it might take a long time when changing a filter property
• Net result is you won’t see any data change until you hit the glowing Apply button on the Properties tab of the Object inspector (unless auto apply is on)

Toggle auto apply
ParaView Dataset Types

- vtkImageData
- vtkRectilinearGrid
- vtkStructuredGrid
- vtkPolyData
- vtkUnstructuredGrid

- Multi-blocks
- AMR
- Time-varying data

- points, cells
- values associated with points and/or cells: scalars, vectors, tensors
Hands on Practice
(see also http://www.paraview.org/Wiki/The_ParaView_Tutorial)

Load disk_out_ref.ex2
  – File→Open… or 📂
  – Tarball/zip file available on above link
  – 5.1.2 installers included at:
    • Windows: <install location>/ParaView 5.1.2/data
    • Linux: <install location>/share/paraview-5.1/data
    • Mac: <install location>/paraview.app/Contents/data
  – An Exodus format file
  – Load all variables
The **Apply** Button & Auto-Apply
Object Inspector: Properties and Information Tabs

Active Filter highlighted
Object Inspector: Information Tab

- Information about the Active Filter’s output
- Dataset type
- Size (bytes, #points, #cells)
- Geometric bounds
- Structured bounds
- Arrays:
  - Name
  - Association =point, =cell
  - Data Type
  - Data Ranges (and scalar/vector)
- Temporal Domain
  - Example data set is static
Manipulate the Data

- Filters Menu
  - Recent
  - Common
  - Data Analysis
  - Statistical
  - Temporal
  - Alphabetical
- Quick Launch
  - PC/Linux
    - CTRL-Space
  - Mac
    - ALT-Space
- Apply Undo/Redo

- Calculator
- Glyph
- Contour
- Stream Tracer
- Clip
- Warp (vector)
- Slice
- Group Datasets
- Threshold
- Extract Group
- Extract Subset
Hands on Practice

- Show as surface with edges to see structure
- Set opacity to 0.5
- Looks like a cylinder with a recess
Hands on Practice

• Apply slice filter
  – Align with z and use 10 offset values
• Color by Temp
• Show Temp lookup table
• Adjust opacity of reader(0.1) and slice(1.0) to see temperature variation clearly
Hands on Practice

- Apply warp filter
  - Warp slices along V vector field with a scale factor of 0.1
- Compare with display of slice
  - Can see how vector field pushes up in center and down further out
  - Seeing convection of a heated gas, it rises at the heat source
Pipeline Browser: Condensed Pipeline Graph

- Use pipeline browser to navigate the graph
- Select a reader/filter to make it active, then object inspector, information tab and display tab pertain to it
- Eyeball is to show/hide filter output in active view

Active Filter highlighted
Display the Data

Representations (aka Displays): visual characteristics of one particular data set in one particular view

Points  Wireframe  Surface  Surface with Edges  Volume
Display the Data

Views – Windows onto one or more data sets
  • Active View has blue border
Exporting Data, Images & Movies

• **Data**
  - File → Save Data…
    • Active filter’s data, prompted for file format
    • Only list of valid file formats shown. Primarily VTK formats + Exodus, Ensight, XDMF/HDF5, csv

• **Images**
  - File → Save Screenshot…
    • Either selected view or all
    • png, bmp, tif, ppm, jpg formats
    • Override Color Palette to get print, presentation, etc. style
  - File → Export Scene…
    • Export visible scene in a format for high quality rendering
    • eps, pdf, ps, svg, pov, vrml, webgl, x3d, x3db formats

• **Movies**
  - File → Save Animation…
    • avi, ogg, ffmpeg → avi formats
Some ParaView Tips & Tricks
Enable/Disable Auto-Apply

Enable for “small” data sets and disable for “large” data sets
mathTeX

Available in:
• Text source (Sources → Text)
• Lookup tables
• Axes Grid titles
• Others…
Views

- Split, expand, pop out views
- 3D view
  - Multiple views – link views for shared interactions
Views (2)

Spreadsheet view

- Sort by min or max in columns by clicking on column header
- Choose which arrays to show
- Cell data can show cell’s points (hidden by default)
- Show only selected points/cells
Views (3)

• Selections linked in all views
• Change View palette
  – Edit→Settings→Color Palette→Load Palette
    • Black, grey, white, print, gradient, default color schemes
  – Can set palette during Save Screenshot just for image export
  – Can set transparent background for screen shots in Edit→Settings→General→Transparent Background (advanced setting 🔄)
• Export as vector graphics:
  – File->Export Scene…
Lookup Tables

• Rainbow lookup table is considered BAD
  – Visual artifacts
  – Color blind considerations
• Lookup tables ranges are linked by variable name
• Can drag Color Legend in view
• Can import new lookup tables
Interpret Values as Categories

- Usually used for cell data
- Click on 📚 to edit lookup table
- Add values first
  - Manual
  - Automatic 📊 📈
- Then choose lookup table 📁❤️
- Can add in text in Annotations
Interpret Values as Categories
Python Scripting

• Useful for performing repetitive tasks
  – pvbatch to run scripts in parallel
• Generate Python scripts with GUI’s trace functionality
  – Can be done incrementally
  – Generate GUI macros
• Can import ParaView into Python shell
  – Prototyped with iPython/Jupyter

http://www.paraview.org/Wiki/ParaView/Python_Scripting
Python Shell

- Tab completion
- Operations in shell are linked with GUI operations
- Can run scripts through Python shell
Online Help

- Email list: paraview@paraview.org
- ParaView
  - www.paraview.org
  - www.paraview.org/Wiki/The_ParaView_Tutorial
  - www.paraview.org/download (installers, source code, build tools, testing data, documentation)
- ParaView Catalyst
  - www.paraview.org/in-situ
- ParaViewWeb: www.paraview.org/Wiki/ParaViewWeb
- VTK-m: m.vtk.org/index.php/Main_Page
- Computational Model Builder
  - www.computationalmodelbuilder.org
  - cmb-users@computationalmodelbuilder.org
  - www.computationalmodelbuilder.org/download (installers, source code, build tools, testing data)
  - www.computationalmodelbuilder.org/documentation
Volume visualization of a terabyte size tornado dataset in ParaView with NVIDIA IndeX (Dataset courtesy of Leigh Orf, U. of Wisconsin-Madison and Rob Sisneros, NCSA)

THANKS!

andy.bauer@kitware.com